On 2/26/26 20:20, Conor Dooley wrote:
[..]
quoted
+ - |
+ #include <dt-bindings/interrupt-controller/arm-gic.h>
+ #include <dt-bindings/interrupt-controller/irq.h>
+
+ bus {
+ #address-cells = <2>;
+ #size-cells = <2>;
+
+ neutron@4ab00000 {
"neutron" is not a generic node name. This should be something like
"accelerator" or similar.
The only dts nodes I could find using accel subsystem are from rockhip. And they use npu@
e.g:
» rknn_core_0: npu@fdab0000 {
» » compatible = "rockchip,rk3588-rknn-core";
Also, Ethos-U64 introduced by Rob with [1] is using npu@.
So, I think we should go wit that. I haven't seen any document to standardize the naming.
[1] https://www.spinics.net/lists/kernel/msg6055856.html