Re: [PATCH v12 00/13] arm64: entry: Convert to Generic Entry
From: Jinjie Ruan <hidden>
Date: 2026-02-04 01:14:36
Also in:
linux-kselftest, lkml
From: Jinjie Ruan <hidden>
Date: 2026-02-04 01:14:36
Also in:
linux-kselftest, lkml
On 2026/2/3 22:16, Thomas Gleixner wrote:
On Tue, Feb 03 2026 at 21:37, Jinjie Ruan wrote:quoted
Currently, x86, Riscv, Loongarch use the Generic Entry which makes maintainers' work easier and codes more elegant. arm64 has already successfully switched to the Generic IRQ Entry in commit b3cf07851b6c ("arm64: entry: Switch to generic IRQ entry"), it is time to completely convert arm64 to Generic Entry. The goal is to bring arm64 in line with other architectures that already use the generic entry infrastructure, reducing duplicated code and making it easier to share future changes in entry/exit paths, such as "Syscall User Dispatch". This patch set is rebased on "sched/core". And the performanceWhy are you using sched/core, which contains a lot of unrelated changes. core/entry is the one which has the prerequisites and nothing else....
Sorry for misunderstanding your v11 reply—however, these patches can still be applied directly to the core/entry branch. Thanks, Jinjie