[PATCH v4 0/3] gpio: brcmstb: wake-up interrupt improvements
From: Florian Fainelli <florian.fainelli@broadcom.com>
Date: 2026-02-03 23:45:37
Also in:
linux-gpio, lkml
From: Florian Fainelli <florian.fainelli@broadcom.com>
Date: 2026-02-03 23:45:37
Also in:
linux-gpio, lkml
Changes in v4: - Provide a leading patch that utilizes irqd_to_hwirq(d) to fetch the HW IRQ number - Utilise .irq_mask and .irq_mask_ack notation in the commit message Changes in v3: - added Linus' R-b tag - removed useless comments Changes in v2: - corrected the patch implementing irq_mask_ack to write properly to the STAT register, this was not the case - create a separate helper to write to the IMASK register to make the code more readable - remove unnecessary cast of unsigned long to u32 Doug Berger (2): gpio: brcmstb: implement .irq_mask_ack gpio: brcmstb: allow parent_irq to wake Florian Fainelli (1): gpio: brcmstb: Utilize irqd_to_hwirq(d) instead of d->hwirq drivers/gpio/gpio-brcmstb.c | 125 +++++++++++++++++++++++++----------- 1 file changed, 87 insertions(+), 38 deletions(-) -- 2.43.0