Re: [PATCH v2 2/2] arm64: dts: rockchip: Add rk3576 evb2 board
From: Chaoyi Chen <hidden>
Date: 2026-01-07 10:03:02
Also in:
linux-devicetree, linux-rockchip, lkml
Hi Heiko, On 1/7/2026 4:21 PM, Heiko Stübner wrote:
Am Mittwoch, 7. Januar 2026, 08:56:04 Mitteleuropäische Normalzeit schrieb Alexey Charkov:quoted
Hi Chaoyi, On Wed, Jan 7, 2026 at 11:04 AM Chaoyi Chen [off-list ref] wrote:quoted
From: Chaoyi Chen <redacted> General features for rk3576 evb2 board: - Rockchip RK3576 - LPDDR4/4X - eMMC5.1 - RK806-2x2pcs + DiscretePower - 1x HDMI2.1 TX / HDMI2.0 RX - 1x full size DP1.4 TX (Only 2 Lanes) - 2x 10/100/1000M Ethernet - 5x SATA3.0 7Pin Slot - 2x USB3.2 Gen1 Host - 3x USB2.0 Host - WIFI/BT - ... Tested with eMMC/SDMMC/HDMI/USB/Ethernet/WIFI/BT module. Signed-off-by: Chaoyi Chen <redacted>[...]quoted
quoted
+ vbus5v0_typec: regulator-vbus5v0-typec { + compatible = "regulator-fixed"; + regulator-name = "vbus5v0_typec";This might better be renamed, given that last time you mentioned this board doesn't have a Type-C connector. Perhaps regulator-vbus5v0-otg?Alternatively a comment above it. I.e. regulator-naming should always follow the naming used in the schematics, so that it gets easier to reference between schematics and devicetree.
Thanks for the explanation. I will fix this in v3.
quoted
quoted
+ regulator-min-microvolt = <5000000>; + regulator-max-microvolt = <5000000>; + enable-active-high; + gpio = <&gpio0 RK_PD1 GPIO_ACTIVE_HIGH>; + vin-supply = <&vcc5v0_device>; + pinctrl-names = "default"; + pinctrl-0 = <&usb_otg0_pwren>; + }; + + vcc12v_dcin: regulator-vcc12v-dcin { + compatible = "regulator-fixed"; + regulator-name = "vcc12v_dcin"; + regulator-always-on; + regulator-boot-on; + regulator-min-microvolt = <12000000>; + regulator-max-microvolt = <12000000>; + }; + + vcc1v2_ufs_vccq_s0: regulator-vcc1v2-ufs-vccq-s0 { + compatible = "regulator-fixed"; + regulator-name = "vcc1v2_ufs_vccq_s0"; + regulator-boot-on; + regulator-always-on; + regulator-min-microvolt = <1200000>; + regulator-max-microvolt = <1200000>; + vin-supply = <&vcc_sys>; + }; + + vcc1v8_ufs_vccq2_s0: regulator-vcc1v8-ufs-vccq2-s0 { + compatible = "regulator-fixed"; + regulator-name = "vcc1v8_ufs_vccq2_s0"; + regulator-boot-on; + regulator-always-on; + regulator-min-microvolt = <1800000>; + regulator-max-microvolt = <1800000>; + vin-supply = <&vcc_1v8_s3>; + }; + + vcc3v3_hubreset: vcc3v3-hubreset { + compatible = "regulator-fixed"; + regulator-name = "vcc3v3_hubreset"; + regulator-boot-on; + regulator-always-on;If this regulator supplies a soldered-on discrete hub and is required to power it up, won't it be better to describe the hub in the device tree (see binding at [1]), make the regulator its supply, and perhaps drop the "regulator-boot-on/regulator-always-on" annotation here, letting the regulator core deal with its enabling instead? [1] https://github.com/torvalds/linux/blob/master/Documentation/devicetree/bindings/usb/usb-device.yamlYep, it would be nicer to it this way. A live example can be found in the Rock 5 ITX [2] [2] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/arch/arm64/boot/dts/rockchip/rk3588-rock-5-itx.dts#n1266
Thank you for the great example. BTW the hub used here is CH344. It looks like we need to add a new binding :)
Heikoquoted
[snip] Other than these, LGTM - thanks for addressing my comments from v1! Feel free to include my: Reviewed-by: Alexey Charkov <alchark@gmail.com> Best regards, Alexey
-- Best, Chaoyi