Hi Neil,
On Sat, Nov 8, 2025 at 10:15 PM Martin Blumenstingl
[off-list ref] wrote:
Commit 85b21fdec906e ("thermal/drivers/generic-adc: Register thermal
zones as hwmon sensors") made "generic-adc-thermal" also register hwmon
attributes. That means we now have the temperature sensor shown twice:
- once from iio-hwmon
- and another time from generic-adc-thermal
We need the latter for SoC temperature control, so simply drop the
former so userspace doesn't see duplicate sensors. Also
generic-adc-thermal provides a better name to userspace
("soc_thermal-virtual-0") than iio_hwmon.
Signed-off-by: Martin Blumenstingl <martin.blumenstingl@googlemail.com>
gentle ping on this