Thread (4 messages) read the whole thread 4 messages, 4 authors, 2026-01-21

Re: [PATCH RESEND] thermal: broadcom: Use clamp to simplify bcm2835_thermal_temp2adc

From: "Luca Ceresoli" <luca.ceresoli@bootlin.com>
Date: 2026-01-05 17:34:22
Also in: linux-pm, lkml

On Mon Jan 5, 2026 at 1:13 PM CET, Thorsten Blum wrote:
Use clamp() to simplify bcm2835_thermal_temp2adc() and improve its
readability. Explicitly cast BIT() to int to prevent a signedness error.

Signed-off-by: Thorsten Blum <thorsten.blum@linux.dev>
Reviewed-by: Luca Ceresoli <luca.ceresoli@bootlin.com>

--
Luca Ceresoli, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help