Thread (3 messages) 3 messages, 3 authors, 2025-09-09

Re: [PATCH] power: supply: Use devm_mutex_init()

From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
Date: 2025-09-09 08:21:41
Also in: kernel-janitors, linux-mediatek, linux-pm, lkml

Il 08/09/25 21:35, Christophe JAILLET ha scritto:
Use devm_mutex_init() instead of hand-writing it.

This saves some LoC, improves readability and saves some space in the
generated .o file.

As an example:
Before:
======
    text	   data	    bss	    dec	    hex	filename
   35803	   9352	    384	  45539	   b1e3	drivers/power/supply/rt9467-charger.o

After:
=====
    text	   data	    bss	    dec	    hex	filename
   34792	   9008	    384	  44184	   ac98	drivers/power/supply/rt9467-charger.o

Signed-off-by: Christophe JAILLET <redacted>
Reviewed-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>


Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help