On Fri, Aug 22, 2025 at 10:49:57AM -0400, Frank Li wrote:
clean up most ls1021a CHECK_DTB warning.
Old uboot check esdhc@1560000. The new uboot already switch to check both
esdhc@1560000 and mmc@1560000. So we can rename it now.
Signed-off-by: Frank Li <Frank.Li@nxp.com>
---
Changes in v3:
- rebase guoshawn/imx/dt tree. Remove patches that were already merged.
- Link to v2: https://lore.kernel.org/r/20250820-ls1021a_dts_warning-v2-0-2e39648a32b7@nxp.com (local)
Changes in v2:
- squash rename to flash patches
- remove duplicate patches already post in
https://lore.kernel.org/linux-devicetree/20250725061339.266125-1-alexander.stein@ew.tq-group.com/ (local)
- Link to v1: https://lore.kernel.org/r/20250818-ls1021a_dts_warning-v1-0-7a79b6b4a0e2@nxp.com (local)
---
Frank Li (4):
ARM: dts: ls1021a: Rename node name nor to flash
ARM: dts: ls1021a: Rename 'mdio-mux-emi1' to 'mdio-mux@54'
ARM: dts: ls1021a: Rename esdhc@1560000 to mmc@1560000
ARM: dts: ls1021a-tsn: Remove redundant #address-cells for ethernet-switch@1
Reviewed-by: Peng Fan <peng.fan@nxp.com>