Thread (19 messages) 19 messages, 3 authors, 2025-09-06
STALE315d LANDED

[PATCH 04/12] lib/crypto: chacha: Rename chacha.c to chacha-block-generic.c

From: Eric Biggers <ebiggers@kernel.org>
Date: 2025-08-27 15:14:58
Also in: linux-crypto, lkml
Subsystem: crypto library, library code, the rest · Maintainers: Eric Biggers, Jason A. Donenfeld, Ard Biesheuvel, Andrew Morton, Linus Torvalds

Rename chacha.c to chacha-block-generic.c to free up the name chacha.c
for the high-level API entry points (chacha_crypt() and
hchacha_block()), similar to the other algorithms.

Signed-off-by: Eric Biggers <ebiggers@kernel.org>
---
 lib/crypto/Makefile                             | 4 ++--
 lib/crypto/{chacha.c => chacha-block-generic.c} | 0
 2 files changed, 2 insertions(+), 2 deletions(-)
 rename lib/crypto/{chacha.c => chacha-block-generic.c} (100%)
diff --git a/lib/crypto/Makefile b/lib/crypto/Makefile
index 8d91572b4d5ef..ca65924e861ff 100644
--- a/lib/crypto/Makefile
+++ b/lib/crypto/Makefile
@@ -13,12 +13,12 @@ obj-$(CONFIG_KUNIT)				+= tests/
 obj-$(CONFIG_CRYPTO_HASH_INFO)			+= hash_info.o
 
 obj-$(CONFIG_CRYPTO_LIB_UTILS)			+= libcryptoutils.o
 libcryptoutils-y				:= memneq.o utils.o
 
-# chacha is used by the /dev/random driver which is always builtin
-obj-y						+= chacha.o
+# chacha20_block() is used by the /dev/random driver which is always builtin
+obj-y						+= chacha-block-generic.o
 obj-$(CONFIG_CRYPTO_LIB_CHACHA_GENERIC)		+= libchacha.o
 
 obj-$(CONFIG_CRYPTO_LIB_AES)			+= libaes.o
 libaes-y					:= aes.o
 
diff --git a/lib/crypto/chacha.c b/lib/crypto/chacha-block-generic.c
similarity index 100%
rename from lib/crypto/chacha.c
rename to lib/crypto/chacha-block-generic.c
-- 
2.50.1

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help