Hi Sangwook
-----Original Message-----
From: Sangwook Shin <redacted>
Sent: Monday, July 14, 2025 11:25 AM
To: krzk@kernel.org; alim.akhtar@samsung.com; wim@linux-watchdog.org;
linux@roeck-us.net
Cc: linux-arm-kernel@lists.infradead.org; linux-samsung-
soc@vger.kernel.org; linux-watchdog@vger.kernel.org; linux-
kernel@vger.kernel.org; Sangwook Shin [off-list ref]
Subject: [PATCH v3 RESEND 1/5] watchdog: s3c2410_wdt: Replace hardcoded
values with macro definitions
Modify the code to utilize macro-defined values instead of hardcoded values.
The value 0x100 in the s3c2410wdt_set_heartbeat function represents
S3C2410_WTCON_PRESCALE_MAX + 1, but it is hardcoded, making its
meaning difficult to understand and reducing code readability.
Signed-off-by: Sangwook Shin <redacted>
---
Reviewed-by: Alim Akhtar <alim.akhtar@samsung.com>