Re: [PATCH v3 04/13] arm64: debug: call step handlers statically
From: Mark Rutland <mark.rutland@arm.com>
Date: 2025-06-18 12:36:50
On Mon, Jun 16, 2025 at 02:39:43PM +0100, Ada Couprie Diaz wrote:
On 13/06/2025 08:47, Anshuman Khandual wrote:quoted
On 09/06/25 11:04 PM, Ada Couprie Diaz wrote:quoted
[...]diff --git a/arch/arm64/kernel/kgdb.c b/arch/arm64/kernel/kgdb.c index b5a3b9c85a65..8f6ce2ea005c 100644 --- a/arch/arm64/kernel/kgdb.c +++ b/arch/arm64/kernel/kgdb.c@@ -250,7 +250,7 @@ int kgdb_compiled_brk_handler(struct pt_regs *regs, unsigned long esr) } NOKPROBE_SYMBOL(kgdb_compiled_brk_handler); -static int kgdb_step_brk_fn(struct pt_regs *regs, unsigned long esr) +int kgdb_singlestep_handler(struct pt_regs *regs, unsigned long esr)This rename makes sense but as mentioned later kgdb_single_step_handler() might save some changes in uprobes callback function.That's fair. I think I would prefer the `_single_step_` version now as well, so I'll go for it.
FWIW, that sounds good to me.
As per the other patch, would it make sense to split the rename here as well ? Would it be OK if it were in the same commit as the breakpoint exception handlers ?
I think it makes sense for the rename to be in this patch, at the point we expose the functions in header files. No need to split that out into a separate patch. Thanks, Mark.