On 11/06/2025 04:10, shao.mingyin@zte.com.cn wrote:
quoted
quoted
From: Shao Mingyin <redacted>
Replace ternary (condition ? "enable" : "disable") syntax and ternary
(condition ? "on" : "off") syntax with helpers from
string_choices.h because:
1. Simple function call with one argument is easier to read. Ternary
operator has three arguments and with wrapping might lead to quite
long code.
2. Is slightly shorter thus also easier to read.
3. It brings uniformity in the text - same string.
4. Allows deduping by the linker, which results in a smaller binary
file.
So you just taken everything from the same my patch - even entire commit
subject and commit description - and sent it as yours?
https://lore.kernel.org/all/20250114203547.1013010-1-krzysztof.kozlowski@linaro.org/ (local)
oh my, if doing EXACTLY the same keep original authorship - the From and
Sob fields.
Best regards,
Krzysztof
Dear Krzysztof,
Thank you for your suggestions. I have carefully read your advice and
made adjustments to the patches accordingly. I used your patch as a
reference standard, not just taking everything from the same your patch.
Based on your suggestion, I have consolidated the series of patches for
I did not suggest to take everything from my patch, add one missing
change and use as yours.
Best regards,
Krzysztof