Thread (79 messages) 79 messages, 3 authors, 2025-06-06

RE: [PATCH v5 21/29] iommufd: Allow an input data_type via iommu_hw_info

From: "Tian, Kevin" <kevin.tian@intel.com>
Date: 2025-05-23 08:07:43
Also in: linux-doc, linux-iommu, linux-kselftest, linux-patches, linux-tegra, lkml

From: Nicolin Chen <redacted>
Sent: Sunday, May 18, 2025 11:22 AM

The iommu_hw_info can output via the out_data_type field the vendor data
type from a driver, but this only allows driver to report one data type.

Now, with SMMUv3 having a Tegra241 CMDQV implementation, it has two
sets
of types and data structs to report.

One way to support that is to use the same type field bidirectionally.

Rename "out_data_type" to simply "data_type", to allow an input for user
space to request for a specific type and to get the corresponding data.

For backward compatibility, since the ioctl handler has never checked an
input value, add a new IOMMU_HW_INFO_FLAG_INPUT_TYPE to switch
between
the old output-only field and the new bidirectional field.

Signed-off-by: Nicolin Chen <redacted>
Reviewed-by: Kevin Tian <kevin.tian@intel.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help