Thread (55 messages) 55 messages, 7 authors, 2025-03-18

Re: [PATCH v3 05/23] iommu/pages: Remove the order argument to iommu_free_pages()

From: Baolu Lu <baolu.lu@linux.intel.com>
Date: 2025-02-26 06:42:36
Also in: asahi, linux-iommu, linux-patches, linux-riscv, linux-rockchip, linux-samsung-soc, linux-sunxi, linux-tegra

On 2/26/25 03:39, Jason Gunthorpe wrote:
Now that we have a folio under the allocation iommu_free_pages() can know
the order of the original allocation and do the correct thing to free it.

The next patch will rename iommu_free_page() to iommu_free_pages() so we
have naming consistency with iommu_alloc_pages_node().

Signed-off-by: Jason Gunthorpe<jgg@nvidia.com>
For changes in intel iommu driver,

Reviewed-by: Lu Baolu <baolu.lu@linux.intel.com>
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help