Thread (5 messages) 5 messages, 5 authors, 2025-01-15

Re: [PATCH] pinctrl: Use str_enable_disable-like helpers

From: Linus Walleij <hidden>
Date: 2025-01-15 11:53:08
Also in: linux-arm-msm, linux-gpio, linux-samsung-soc, linux-sound, lkml

On Tue, Jan 14, 2025 at 9:36 PM Krzysztof Kozlowski
[off-list ref] wrote:
Replace ternary (condition ? "enable" : "disable") syntax with helpers
from string_choices.h because:
1. Simple function call with one argument is easier to read.  Ternary
   operator has three arguments and with wrapping might lead to quite
   long code.
2. Is slightly shorter thus also easier to read.
3. It brings uniformity in the text - same string.
4. Allows deduping by the linker, which results in a smaller binary
   file.

Signed-off-by: Krzysztof Kozlowski <redacted>
Patch applied!

Yours,
Linus Walleij
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help