Thread (2 messages) 2 messages, 2 authors, 2025-01-14

Re: [PATCH] gpio: Use str_enable_disable-like helpers

From: Florian Fainelli <florian.fainelli@broadcom.com>
Date: 2025-01-14 17:36:41
Also in: linux-gpio, lkml

On 1/14/25 02:55, Krzysztof Kozlowski wrote:
Replace ternary (condition ? "enable" : "disable") syntax with helpers
from string_choices.h because:
1. Simple function call with one argument is easier to read.  Ternary
    operator has three arguments and with wrapping might lead to quite
    long code.
2. Is slightly shorter thus also easier to read.
3. It brings uniformity in the text - same string.
4. Allows deduping by the linker, which results in a smaller binary
    file.

Signed-off-by: Krzysztof Kozlowski <redacted>
---
  drivers/gpio/gpio-brcmstb.c | 3 ++-
Reviewed-by: Florian Fainelli <florian.fainelli@broadcom.com>
-- 
Florian
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help