Re: [PATCH v2 4/5] PCI: stm32: Add PCIe endpoint support for STM32MP25
From: Bjorn Helgaas <helgaas@kernel.org>
Date: 2025-01-14 17:05:33
Also in:
linux-devicetree, linux-pci, lkml
On Mon, Dec 16, 2024 at 03:00:58PM +0100, Christian Bruel wrote:
On 12/5/24 18:27, Bjorn Helgaas wrote:quoted
On Tue, Nov 26, 2024 at 04:51:18PM +0100, Christian Bruel wrote:quoted
Add driver to configure the STM32MP25 SoC PCIe Gen2 controller based on the DesignWare PCIe core in endpoint mode.
quoted
quoted
+static void stm32_pcie_ep_init(struct dw_pcie_ep *ep) +{ + struct dw_pcie *pci = to_dw_pcie_from_ep(ep); + struct stm32_pcie *stm32_pcie = to_stm32_pcie(pci); + enum pci_barno bar; + + for (bar = 0; bar < PCI_STD_NUM_BARS; bar++) + dw_pcie_ep_reset_bar(pci, bar); + + /* Defer Completion Requests until link started */I asked about this before [1] but didn't finish the conversation. My main point is that I think "Completion Request" is a misnomer. There's a "Configuration Request" and a "Completion," but no such thing as a "Completion Request." Based on your previous response, I think this should say something like "respond to config requests with Request Retry Status (RRS) until we're prepared to handle them."OK thanks for the phrasing. This is inline with the DWC doc: "... controller completes incoming configuration requests with a configuration request retry status." The only thing is that the PCIe specs talks about CRS, not RRS. so slightly change to "respond to config requests with Configuration Request Retry Status (CRS) until we're prepared to handle them."
This terminology between PCIe r5.0 and r6.0. In r5.0, sec 2.2.9 labels Completion Status value 010b as "Configuration Request Retry Status (CRS)", but in r6.0, sec 2.2.9.1 labels that same value as "Request Retry Status (RRS)". We changed most usage inside drivers/pci/ to align with the r6.0 term with https://git.kernel.org/linus/87f10faf166a ("PCI: Rename CRS Completion Status to RRS"). But with respect to this patch, changing "Completion Request" to "Configuration Request" is the main thing. Bjorn