Thread (77 messages) 77 messages, 4 authors, 2025-01-23

Re: [PATCH v5 03/14] iommufd/fault: Move iommufd_fault_iopf_handler() to header

From: Jason Gunthorpe <jgg@nvidia.com>
Date: 2025-01-10 17:25:29
Also in: linux-doc, linux-iommu, linux-kselftest, linux-patches, lkml

On Tue, Jan 07, 2025 at 09:10:06AM -0800, Nicolin Chen wrote:
The new vEVENTQ object will need a similar function for drivers to report
the vIOMMU related events. Split the common part out to a smaller helper,
and place it in the header so that CONFIG_IOMMUFD_DRIVER_CORE can include
that in the driver.c file for drivers to use.

Then keep iommufd_fault_iopf_handler() in the header too, since it's quite
simple after all.

Reviewed-by: Kevin Tian <kevin.tian@intel.com>
Reviewed-by: Lu Baolu <baolu.lu@linux.intel.com>
Signed-off-by: Nicolin Chen <redacted>
---
 drivers/iommu/iommufd/iommufd_private.h | 20 +++++++++++++++++++-
 drivers/iommu/iommufd/fault.c           | 17 -----------------
 2 files changed, 19 insertions(+), 18 deletions(-)
Reviewed-by: Jason Gunthorpe <jgg@nvidia.com>

Jason
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help