Thread (38 messages) 38 messages, 5 authors, 2024-12-27

Re: [PATCH v3 04/15] phy: phy-rockchip-samsung-hdptx: Rename some register names related to DP

From: Dmitry Baryshkov <hidden>
Date: 2024-12-20 02:01:18
Also in: dri-devel, linux-devicetree, linux-phy, linux-rockchip, lkml

On Fri, Dec 20, 2024 at 09:46:24AM +0800, Damon Ding wrote:
Hi Dmitry,

On 2024/12/20 8:22, Dmitry Baryshkov wrote:
quoted
On Thu, Dec 19, 2024 at 04:05:53PM +0800, Damon Ding wrote:
quoted
The modifications of DP register names are as follows:
- Add the '_MASK' suffix to some registers to ensure consistency.
- Complete the names of some register to their full names.
- Swap the definitions of LCPLL_REF and ROPLL_REF.
Three unrelated changes, ideally means three commits (I won't insist on
that though). Also please mention that LCPLL_REF and ROPLL_REF were not
used by the existing driver, so it's not a bug and there is no need to
backport it.
Indeed, it would be better to split this patch into three different commits.
However, I still want to keep the fixes for LCPLL_REF and ROPLL_REF because,
according to the datasheet, they are indeed incorrect. And I will describe
the suggestions you mentioned in the commit message.
I meant that the issue with those defines doesn't affect existing code,
so there is no need for Fixes:, etc.


-- 
With best wishes
Dmitry
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help