Thread (27 messages) 27 messages, 5 authors, 2024-08-13

Re: [PATCH v6 02/10] cpuidle: rename ARCH_HAS_CPU_RELAX to ARCH_HAS_OPTIMIZED_POLL

From: "Christoph Lameter (Ampere)" <cl@gentwo.org>
Date: 2024-08-06 01:03:36
Also in: kvm, linux-pm, lkml

On Fri, 26 Jul 2024, Ankur Arora wrote:
However, recent changes in poll_idle() mean that a higher level
primitive -- smp_cond_load_relaxed() is used for polling. This would
in-turn use cpu_relax() or an architecture specific implementation.

Maybe explain here that smp_cond_load_relaxed will potentially wait for 
important events such as a cacheline changing. Thereby making the busy 
poll unnecessary and optimizing power use.

Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help