Re: [PATCH] hwrng: stm32 - use sizeof(*priv) instead of sizeof(struct stm32_rng_private)
From: Uwe Kleine-König <ukleinek@kernel.org>
Date: 2024-05-31 10:50:48
Also in:
linux-crypto
From: Uwe Kleine-König <ukleinek@kernel.org>
Date: 2024-05-31 10:50:48
Also in:
linux-crypto
On Fri, May 31, 2024 at 10:57:34AM +0200, Marek Vasut wrote:
Use sizeof(*priv) instead of sizeof(struct stm32_rng_private), the former makes renaming of struct stm32_rng_private easier if necessary, as it removes one site where such rename has to happen. No functional change.
IMHO the main upside is that it's easier to spot that the allocation size is correct. Acked-by: Uwe Kleine-König <ukleinek@kernel.org> Best regards Uwe -- Pengutronix e.K. | Uwe Kleine-König | Industrial Linux Solutions | https://www.pengutronix.de/ |