Thread (46 messages) 46 messages, 7 authors, 2024-05-27

Re: [PATCH v5 17/17] serial: 8250: Add 8250_acpi driver

From: Sunil V L <sunilvl@ventanamicro.com>
Date: 2024-05-03 13:59:50
Also in: linux-acpi, linux-pci, linux-riscv, linux-serial, lkml

On Thu, May 02, 2024 at 06:35:52PM +0300, Andy Shevchenko wrote:
On Thu, May 02, 2024 at 04:50:57PM +0530, Sunil V L wrote:
quoted
On Thu, May 02, 2024 at 01:09:57PM +0300, Andy Shevchenko wrote:
quoted
On Thu, May 02, 2024 at 03:20:08PM +0530, Sunil V L wrote:
quoted
On Thu, May 02, 2024 at 12:17:59PM +0300, Andy Shevchenko wrote:
...
quoted
quoted
quoted
This driver is not a duplicate of 8250_pnp. It just relies on UART
enumerated as platform device instead of using PNP interfaces.
Isn't it better and simple to have an option to enumerate as platform
device instead of PNP? 
Ah, then extract platform driver first from 8250_core.c.
Let me know if I understand your suggestion correctly. Do you mean call
something like serial8250_acpi_init() from serial8250_init() and
register the driver directly in serial8250_acpi_init()?
Extract the code to be 8250_platform.c and update that file.
I have locally the extraction of RSA code, I will see if I can help you
with the rest.
Thanks!. That will be helpful. TBH, I don't understand what to do for
extracting the platform driver code. There are already several vendor
specific UART drivers (ex: 8250_fsl.c) which are enumerated as platform
devices. 8250_core.c looks cleanly supporting such drivers which can
register themselves with the core. For generic UART, DT has 8250_of.c
and ACPI has 8250_pnp.c. But 8250_pnp.c comes with baggage of PNP
contract. So, the driver in this patch is similar to vendor specific
drivers to support generic uart devices which are enumerated as platform
device. I can rename 8250_acpi.c to 8250_platform.c if that is better.

Could you please help with a patch even if not compiled so that I can
understand your suggestion better? 

Thanks for your help!
Sunil

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help