Hi Andy,
Le mercredi 13 décembre 2023 à 15:21 +0200, Andy Shevchenko a écrit :
On Wed, Dec 13, 2023 at 10:55:46AM +0100, Paul Cercueil wrote:
quoted
Le lundi 11 décembre 2023 à 20:57 +0200, Andy Shevchenko a écrit :
...
quoted
quoted
-#define INGENIC_PIN_GROUP(name, id, func) \
- INGENIC_PIN_GROUP_FUNCS(name, id, (void *)(func))
+#define INGENIC_PIN_GROUP(_name_, id,
func) \
+ {
\
+ .name =
_name_, \
+ .pins =
id##_pins, \
+ .num_pins =
ARRAY_SIZE(id##_pins), \
+ .data = (void
*)func, \
+ }
This INGENIC_PIN_GROUP() macro doesn't need to be modified, does
it?
We can go either way. I prefer to go this way as it reduces level of
indirections in the macros. It makes code easier to read and
understand.
But if you insist, I can drop that change in next version.
I like the patches to be minimal. But I understand your point of view
as well.
If you have to issue a v6, maybe state the reason why you also modify
INGENIC_PIN_GROUP() then. But I don't care enough to request a v6 just
for that.
So:
Acked-by: Paul Cercueil <paul@crapouillou.net>
Cheers,
-Paul
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel