On Tue, Aug 29, 2023 at 03:40:26PM +0200, Fabrice Gasnier wrote:
quoted hunk ↗ jump to hunk
Rename "Channel 1 Quadrature B", as it corresponds to timer input ch2.
I suspect it referred to the (unique) counter earlier, but the physical
input really is CH2.
Signed-off-by: Fabrice Gasnier <fabrice.gasnier@foss.st.com>
---
drivers/counter/stm32-timer-cnt.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/counter/stm32-timer-cnt.c b/drivers/counter/stm32-timer-cnt.c
index 6206d2dc3d47..eae851f6db2c 100644
--- a/drivers/counter/stm32-timer-cnt.c
+++ b/drivers/counter/stm32-timer-cnt.c
@@ -283,7 +283,7 @@ static struct counter_signal stm32_signals[] = {
},
{
.id = 1,
- .name = "Channel 1 Quadrature B"
+ .name = "Channel 2 Quadrature B"
}
};
--
2.25.1
If these signals are going to be named after their channels, then I
prefer we just remove the "Quadrature A" and "Quadrature B" conventions
and leave the signals named "Channel 1" and "Channel 2" respectively.
William Breathitt Gray