RE: [EXT] Re: [PATCH v7 3/7] dt-bindings: display: bridge: Add Cadence MHDP850
From: Sandor Yu <hidden>
Date: 2023-07-19 02:32:54
Also in:
dri-devel, linux-devicetree, linux-phy, lkml
Hi Rob, Thanks for your comment.
quoted
Hi Alexander, Thanks for your comments,quoted
Am Montag, 17. Juli 2023, 10:03:49 CEST schrieb Sandor Yu:quoted
******************** Achtung externe E-Mail: Öffnen Sie Anhänge und Links nur, wenn Sie wissen, dass diese aus einer sicheren Quelle stammen und sicher sind. Leiten Sie die E-Mail im Zweifelsfall zur Prüfung an den IT-Helpdeskweiter.quoted
quoted
quoted
Attention external email: Open attachments and links only if you know that they are from a secure source and are safe. In doubt forward the email to the IT-Helpdesk to check it. ******************** Add bindings for Cadence MHDP8501 DisplayPort/HDMI bridge.. Signed-off-by: Sandor Yu <redacted> --- .../display/bridge/cdns,mhdp8501.yaml | 105++++++++++++++++++quoted
1 file changed, 105 insertions(+) create mode 100644Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.yamquoted
quoted
quoted
l diff --git a/Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.y aml b/Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.y aml new file mode 100644 index 000000000000..b983ee765f54--- /dev/null +++b/Documentation/devicetree/bindings/display/bridge/cdns,mhdp8501.yquoted
+++ aml@@ -0,0 +1,105 @@ +# SPDX-License-Identifier: (GPL-2.0 OR BSD-2-Clause) %YAML 1.2 +--- +$id: +http://devi/+cetree.org%2Fschemas%2Fdisplay%2Fbridge%2Fcdns%2Cmhdp8501.yaml%quoted
quoted
23&datquoted
+a=05%7C01%7CSandor.yu%40nxp.com%7C603a90f3f3c34d32a1e708db86aquoted
quoted
8f868%7Cquoted
+686ea1d3bc2b4c6fa92cd99c5c301635%7C0%7C0%7C63825183250590544quoted
quoted
2%7CUnknoquoted
+wn%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1quoted
quoted
haWwiquoted
+LCJXVCI6Mn0%3D%7C3000%7C%7C%7C&sdata=JnbufeZplo%2B6JGW4HaKquoted
quoted
%2BLyC0MESKquoted
+GsV%2FtjfeXCXqK4U%3D&reserved=0 +$schema: +http://devi/+cetree.org%2Fmeta-schemas%2Fcore.yaml%23&data=05%7C01%7CSandor.quoted
quoted
yu%40nquoted
+xp.com%7C603a90f3f3c34d32a1e708db86a8f868%7C686ea1d3bc2b4c6fa9quoted
quoted
2cd99c5quoted
+c301635%7C0%7C0%7C638251832505905442%7CUnknown%7CTWFpbGZsquoted
quoted
b3d8eyJWIjoiquoted
+MC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3quoted
quoted
000%7C%quoted
+7C%7C&sdata=rdOyjVz4gGnToVC40Rcfp%2Fk925yC%2F6xNwGbBAnOtcDQquoted
quoted
%3D&reservquoted
+ed=0 + +title: Cadence MHDP8501 DP/HDMI bridge + +maintainers: + - Sandor Yu [off-list ref] + +description: + Cadence MHDP8501 DisplayPort/HDMI interface. + +properties: + compatible: + enum: + - cdns,mhdp8501 + - fsl,imx8mq-mhdp8501 + + reg: + maxItems: 1 + + clocks: + maxItems: 1 + description: MHDP8501 DP/HDMI APB clock. + + phys: + maxItems: 1 + description: + phandle to the DisplayPort or HDMI PHY + + interrupts: + items: + - description: Hotplug cable plugin. + - description: Hotplug cable plugout. + + interrupt-names: + items: + - const: plug_in + - const: plug_out + + ports: + $ref: /schemas/graph.yaml#/properties/ports + + properties: + port@0: + $ref: /schemas/graph.yaml#/properties/port + description: + Input port from display controller output. + port@1: + $ref: /schemas/graph.yaml#/properties/port + description: + Output port to DisplayPort or HDMI connector. + + required: + - port@0 + - port@1 + +required: + - compatible + - reg + - clocks + - interrupts + - interrupt-names + - phys + - ports + +additionalProperties: false + +examples: + - | + #include <dt-bindings/clock/imx8mq-clock.h> + #include <dt-bindings/interrupt-controller/arm-gic.h> + + mhdp_dp: dp-bridge@32c00000 {I'm not sure, but I would name this node just 'bridge', because it can be either DP or HDMI depending on the connector. But DT folks will know better than me.This name should update too after DP and HDMI driver combined.Has nothing to do with a driver.quoted
I will change to "mhdp: mhdp-bridge@32c00000" in the next version.What is 'mhdp'? Doesn't sound generic. Use just 'bridge' or 'display-bridge'. We don't have a standard name defined in the DT spec (there's 'hdmi', but nothing that's protocol independent).
OK, thanks, will change to "mhdp: display-bridge@32c00000". B.R Sandor
Rob
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel