Re: [PATCH v3 3/3] clk: nuvoton: Use clk_parent_data instead of string for parent clock
From: Jacky Huang <hidden>
Date: 2023-06-27 05:43:15
Also in:
linux-clk, lkml
On 2023/6/27 上午 12:09, Stephen Boyd wrote:
Quoting Jacky Huang (2023-06-22 07:13:43)quoted
From: Jacky Huang <ychuang3@nuvoton.com> For the declaration of parent clocks, use struct clk_parent_data instead of a string. Due to the change in the passed arguments, replace the usage of devm_clk_hw_register_mux() with clk_hw_register_mux_parent_data() for all cases. Signed-off-by: Jacky Huang <ychuang3@nuvoton.com> --- drivers/clk/nuvoton/clk-ma35d1.c | 306 ++++++++++++++++++++++--------- 1 file changed, 219 insertions(+), 87 deletions(-)diff --git a/drivers/clk/nuvoton/clk-ma35d1.c b/drivers/clk/nuvoton/clk-ma35d1.c index 733750dda0f4..f1fe7edd21b5 100644 --- a/drivers/clk/nuvoton/clk-ma35d1.c +++ b/drivers/clk/nuvoton/clk-ma35d1.c@@ -63,167 +63,298 @@ static DEFINE_SPINLOCK(ma35d1_lock); #define PLL_MODE_SS 2 static const struct clk_parent_data ca35clk_sel_clks[] = { - { .index = 0 }, /* HXT */ - { .index = 1 }, /* CAPLL */ - { .index = 2 } /* DDRPLL */ + { .fw_name = "hxt", }, + { .fw_name = "capll", }, + { .fw_name = "ddrpll", },Is there any reason why this changed from numbers to strings? It is faster to directly index vs. access the clock-names property. The preference is to use the index field and only use fw_name if we're migrating legacy clk drivers to use DT based lookups.
This is simply because I think strings are more readable than numbers. Since using an index is the preferred method, I will change all occurrences of ".fw_name" to ".index" and add comments to describe it. As this patch was applied, I will create another patch relative to this one. Best Regards, Jacky Huang _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel