Thread (1 message) 1 message, 1 author, 2023-05-25

Re: [PATCH 03/23] arm64/hugetlb: pte_alloc_huge() pte_offset_huge()

From: Catalin Marinas <catalin.marinas@arm.com>
Date: 2023-05-25 16:38:02
Also in: linux-m68k, linux-mips, linux-mm, linux-riscv, linux-s390, linux-sh, linuxppc-dev, lkml, sparclinux

On Tue, May 09, 2023 at 09:45:57PM -0700, Hugh Dickins wrote:
pte_alloc_map() expects to be followed by pte_unmap(), but hugetlb omits
that: to keep balance in future, use the recently added pte_alloc_huge()
instead; with pte_offset_huge() a better name for pte_offset_kernel().

Signed-off-by: Hugh Dickins <hughd@google.com>
Acked-by: Catalin Marinas <catalin.marinas@arm.com>

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help