Re: [PATCH v4 1/2] media: dt-bindings: mediatek: Rename child node names for decoder
From: Krzysztof Kozlowski <hidden>
Date: 2022-11-24 11:09:16
Also in:
linux-devicetree, linux-media, linux-mediatek, lkml
On 24/11/2022 12:05, Hans Verkuil wrote:
Hi Krzysztof, On 05/10/2022 13:58, Allen-KH Cheng (程冠勳) wrote:quoted
Hi Krzysztof, On Wed, 2022-10-05 at 09:30 +0200, Krzysztof Kozlowski wrote:quoted
On 05/10/2022 09:21, Allen-KH Cheng (程冠勳) wrote:quoted
Hi Rob, On Fri, 2022-09-30 at 17:00 -0500, Rob Herring wrote:quoted
On Fri, Sep 30, 2022 at 07:22:36PM +0800, Allen-KH Cheng wrote:quoted
In order to make the names of the child nodes more generic, we rename "vcodec" to "video-codec" for decoder in patternProperties and example.They are either generic or they aren't. Until something generic is defined, I don't think it's worth the churn to change.quoted
Signed-off-by: Allen-KH Cheng <redacted> Reviewed-by: AngeloGioacchino Del Regno < angelogioacchino.delregno@collabora.com> --- .../bindings/media/mediatek,vcodec-subdev-decoder.yaml | 8 ++++---- 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/Documentation/devicetree/bindings/media/mediatek,vcodec- subdev- decoder.yaml b/Documentation/devicetree/bindings/media/mediatek,vcodec- subdev- decoder.yaml index c4f20acdc1f8..67fde48f991c 100644--- a/Documentation/devicetree/bindings/media/mediatek,vcodec-subdev-decoder.yaml+++ b/Documentation/devicetree/bindings/media/mediatek,vcodec-subdev-decoder.yaml@@ -91,7 +91,7 @@ properties: # Required child node: patternProperties: - '^vcodec-lat@[0-9a-f]+$': + '^video-codec-lat@[0-9a-f]+$':Just 'video-codec' doesn't work?Thanks for your reply. hmm, I think 'vidoe-codec' does wrok. There are two seperate hardwares for the MTK video codec. codec-lat and codec-core. Is it ok to keep two child node names for various hardwares?Aren't they still codecs? Best regards, KrzysztofYes, They are both hardware deocders. Lat is responsible for the bitstream and write the outcome to the lat buffer. Core will decode the lat buffer and write the outcome to the output buffer. Each frame will be decoded cyclically by these two hardware deocders.So is this patch OK to be merged? Or do you still want changes?
The patch should be changed as Rob pointed out - use "video-codec" name. Best regards, Krzysztof _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel