On 08/06/22 at 10:29am, Kefeng Wang wrote:
...snip...
quoted
quoted
diff --git a/include/asm-generic/io.h b/include/asm-generic/io.h
index 72974cb81343..d72eb310fb3c 100644
--- a/include/asm-generic/io.h
+++ b/include/asm-generic/io.h
@@ -967,26 +967,27 @@ static inline void iounmap(volatile void __iomem *addr)
/*
* Arch code can implement the following two hooks when using GENERIC_IOREMAP
* ioremap_allowed() return a bool,
- * - true means continue to remap
- * - false means skip remap and return directly
+ * - IS_ERR means return an error
+ * - NULL means continue to remap
+ * - a non-NULL, non-IS_ERR pointer is returned directly
If ioremap_allowed() returns a valid pointer, then the function name
is not as precise anymore.
Maybe use arch_ioremap/unmap as before, or some better name.
Looks good to me. Or ioremap_check() which is a generic name, and
usually xxx_check() can hanlde many things.
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel