Re: [PATCH v4 01/20] dt-bindings: iommu: mediatek: Increase max interrupt number
From: Yong Wu <yong.wu@mediatek.com>
Date: 2022-08-01 12:24:46
Also in:
linux-devicetree, linux-iommu, linux-mediatek, lkml
On Fri, 2022-07-29 at 14:31 +0800, Tinghan Shen wrote:
quoted hunk ↗ jump to hunk
mt8195 infra iommu uses 5 interrupts. Signed-off-by: Tinghan Shen <redacted> Reviewed-by: Krzysztof Kozlowski <redacted> --- .../bindings/iommu/mediatek,iommu.yaml | 18 +++++++++++++++++- 1 file changed, 17 insertions(+), 1 deletion(-) diff --git a/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml b/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml index fee0241b50988..5afe2a0045330 100644--- a/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml +++ b/Documentation/devicetree/bindings/iommu/mediatek,iommu.yaml@@ -91,7 +91,8 @@ properties: maxItems: 1 interrupts: - maxItems: 1 + minItems: 1 + maxItems: 5 clocks: items:@@ -191,9 +192,24 @@ allOf: const: mediatek,mt8195-iommu-infra then: + properties: + interrupts: + maxItems: 1 + required: - mediatek,larbs + else: + properties: + interrupts: + description: The IOMMU has 5 banks. Each bank has its owninterrupt. + items: + - description: The interrupt for IOMMU bank0 + - description: The interrupt for IOMMU bank1 + - description: The interrupt for IOMMU bank2 + - description: The interrupt for IOMMU bank3 + - description: The interrupt for IOMMU bank4 +
Thanks for improving this.
Before the meaning for this segment is that it require "mediatek,larbs"
if it is NOT infra iommu. Here we add a new block for infra iommu.
then we'd better to remove the "not". this should be more readable.
Something like below:
if:
/* Remove the not here. */
properties:
compatible:
contains:
const: mediatek,mt8195-iommu-infra
then:
xxx
else:
xx
additionalProperties: false examples:
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel