On Tue, 19 Jul 2022 17:11:32 +0100,
Sean Christopherson [off-list ref] wrote:
Honestly, I think pKVM is simply being too cute in picking names.
I don't know what you mean by "cute" here, but I assume this is not
exactly a flattering qualifier.
And not just for "shadow", e.g. IMO the flush/sync terminology in
patch 24 is also unnecessarily cute. Instead of coming up with
clever names, just be explicit in what the code is doing.
E.g. something like:
flush_shadow_state() => sync_host_to_pkvm_vcpu()
sync_shadow_state() => sync_pkvm_to_host_vcpu()
As much as I like bikesheding, this isn't going to happen. We have had
the sync/flush duality since day one, we have a lot of code based
around this naming, and departing from it seems counter productive.
M.
--
Without deviation from the norm, progress is not possible.
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel