Re:Re: [PATCH] clk/meson: Hold reference returned by of_get_parent()
From: Liang He <hidden>
Date: 2022-06-26 23:43:05
Also in:
linux-amlogic, linux-clk
At 2022-06-27 06:02:45, "Martin Blumenstingl" [off-list ref] wrote:
Hello, thank you for submitting this patch! On Fri, Jun 24, 2022 at 12:28 PM Liang He [off-list ref] wrote: [...]quoted
these bugs are compiled tested in 5.19rc2 with at91_dt_defconfigPlease note that you're changing some drivers which are only in the arch/arm/configs/multi_v7_defconfig while others are only in arch/arm64/configs/defconfig I think at91_dt_defconfig will not compile any of the drivers below
Hi, Martin. To simplify the building test, I use the at91_dt_defconfig to build .config for these similar bugs in clk-at91, clk-sprd,etc. Then I use following command to complete different compile tests for clk-meson: make CONFIG_ARCH_MESON=y CONFIG_COMMON_CLK_MESON8B=y CROSS_COMPILE=arm-linux-gnueabi- ARCH=arm ./drivers/clk/meson/meson8b.o make CONFIG_ARCH_MESON=y CONFIG_COMMON_CLK_MESON_EE_CLKC=y CROSS_COMPILE=arm-linux-gnueabi- ARCH=arm ./drivers/clk/meson/meson-eeclk.o make CONFIG_ARCH_MESON=y CONFIG_COMMON_CLK_MESON_AO_CLKC=y CROSS_COMPILE=arm-linux-gnueabi- ARCH=arm ./drivers/clk/meson/meson-aoclk.o I will add these detailed compile commands in my version-2 patch and also in future patch commit.
[...]quoted
diff --git a/drivers/clk/meson/meson8b.c b/drivers/clk/meson/meson8b.c index 8f3b7a94a667..54188319f349 100644 --- a/drivers/clk/meson/meson8b.c +++ b/drivers/clk/meson/meson8b.c@@ -3796,8 +3796,11 @@ static void __init meson8b_clkc_init_common(struct device_node *np, struct clk *notifier_clk; struct regmap *map; int i, ret; + struct device_node *tp;This function uses reverse christmas tree sorting, so the longest line goes on top while the shortest should stay on the bottom. Can you please explain what "tp" stands for? Personally I would call this variable parent_np, but maybe "tp" has a similar meaning. Best regards, Martin
Thanks very much, Martin. I will send version-2 patch to keep the reverse christmas tree. And I will follow this rule in my future patch code. I just want to ues 'tp' as 'tmp_pointer', but your advice is more reasonable and I will change that in version-2 patch. Liang _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel