Re: [PATCH 2/5] pinctrl: mediatek: common-v1: Add common probe function
From: Chen-Yu Tsai <wenst@chromium.org>
Date: 2022-02-21 04:33:40
Also in:
linux-gpio, linux-mediatek, lkml
From: Chen-Yu Tsai <wenst@chromium.org>
Date: 2022-02-21 04:33:40
Also in:
linux-gpio, linux-mediatek, lkml
On Thu, Feb 10, 2022 at 10:20 PM AngeloGioacchino Del Regno [off-list ref] wrote:
As a preparation to cleanup the probe mechanism of mediatek pinctrl drivers that are using the v1 controller, add a common probe function to this driver. Signed-off-by: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
Reviewed-by: Chen-Yu Tsai <wenst@chromium.org> but
--- drivers/pinctrl/mediatek/pinctrl-mtk-common.c | 11 +++++++++++ drivers/pinctrl/mediatek/pinctrl-mtk-common.h | 2 ++ 2 files changed, 13 insertions(+)diff --git a/drivers/pinctrl/mediatek/pinctrl-mtk-common.c b/drivers/pinctrl/mediatek/pinctrl-mtk-common.c index 6f8dfa6ae5a0..007da39b68c9 100644 --- a/drivers/pinctrl/mediatek/pinctrl-mtk-common.c +++ b/drivers/pinctrl/mediatek/pinctrl-mtk-common.c@@ -1115,3 +1115,14 @@ int mtk_pctrl_init(struct platform_device *pdev, gpiochip_remove(pctl->chip); return ret; } + +int mtk_pctrl_common_probe(struct platform_device *pdev) +{ + struct device *dev = &pdev->dev; + const struct mtk_pinctrl_devdata *data = device_get_match_data(dev); + + if (!data) + return -ENOENT;
This is probably bikeshedding, but it seems most other drivers use -ENODEV or -EINVAL. -ENOENT is seldomly used in this context. ChenYu _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel