Re: [PATCH v4 1/6] KVM: arm64: Correctly treat writes to OSLSR_EL1 as undefined
From: Mark Rutland <mark.rutland@arm.com>
Date: 2021-12-15 14:33:24
Also in:
kvm, kvmarm
On Wed, Dec 15, 2021 at 01:09:28PM +0000, Oliver Upton wrote:
Hi Mark, On Wed, Dec 15, 2021 at 11:39:58AM +0000, Mark Rutland wrote:quoted
Hi Oliver, On Tue, Dec 14, 2021 at 05:28:07PM +0000, Oliver Upton wrote:quoted
Any valid implementation of the architecture should generate an undefined exception for writes to a read-only register, such as OSLSR_EL1. Nonetheless, the KVM handler actually implements write-ignore behavior. Align the trap handler for OSLSR_EL1 with hardware behavior. If such a write ever traps to EL2, inject an undef into the guest and print a warning.I think this can still be read amibguously, since we don't explicitly state that writes to OSLSR_EL1 should never trap (and the implications of being UNDEFINED are subtle). How about: | Writes to OSLSR_EL1 are UNDEFINED and should never trap from EL1 to EL2, but | the KVM trap handler for OSLSR_EL1 handlees writes via ignore_write(). This
Whoops, with s/handlees/handles/
quoted
| is confusing to readers of the code, but shouldn't have any functional impact. | | For clarity, use write_to_read_only() rather than ignore_write(). If a trap | is unexpectedly taken to EL2 in violation of the architecture, this will | WARN_ONCE() and inject an undef into the guest.Agreed, I like your suggested changelog better :-)
Cool! Mark.
quoted
With that: Reviewed-by: Mark Rutland <mark.rutland@arm.com>Thanks! -- Best, Oliver
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel