On Tue Dec 14 2021, Vladimir Oltean wrote:
This OF property was supposed to be named "fsl,extirq-map" since the
first patch submissions, but at Rob Herring's suggestion it was named
"interrupt-map":
https://lore.kernel.org/lkml/20190927161118.GA19333@bogus/ (local)
nit: The preferred form is https://lore.kernel.org/r/<message-id>
[snip]
quoted hunk ↗ jump to hunk
diff --git a/drivers/irqchip/irq-ls-extirq.c b/drivers/irqchip/irq-ls-extirq.c
index 853b3972dbe7..b6ecc5e3472f 100644
--- a/drivers/irqchip/irq-ls-extirq.c
+++ b/drivers/irqchip/irq-ls-extirq.c
@@ -101,9 +101,15 @@ ls_extirq_parse_map(struct ls_extirq_data *priv, struct device_node *node)
u32 mapsize;
int ret;
- map = of_get_property(node, "interrupt-map", &mapsize);
- if (!map)
- return -ENOENT;
+ map = of_get_property(node, "fsl,extirq-map", &mapsize);
+ if (!map) {
+ map = of_get_property(node, "interrupt-map", &mapsize);
+ if (!map)
+ return -ENOENT;
+
+ pr_warn("\"interrupt-map\" is a reserved OF property, and support for it will be removed. Please use \"fsl,extirq-map\" instead.\n");
+ }
Looks reasonable. For instance, DSA does the same thing wrt "ports"
vs. "ethernet-ports".
Thanks,
Kurt