On Thu, 9 Dec 2021 09:42:25 +0800, Yunfeng Ye wrote:
The commit 0c8ea531b774 ("arm64: mm: Allocate ASIDs in pairs") introduce
the asid2idx and idx2asid macro, but these macros are not really useful
after the commit f88f42f853a8 ("arm64: context: Free up kernel ASIDs if
KPTI is not in use").
The code "(asid & ~ASID_MASK)" can be instead by a macro, which is the
same code with asid2idx(). So rename it to ctxid2asid() for a better
understanding.
[...]
Applied to arm64 (for-next/misc), thanks!
[1/2] arm64: mm: Rename asid2idx() to ctxid2asid()
https://git.kernel.org/arm64/c/a3a5b763410c
[2/2] arm64: mm: Use asid feature macro for cheanup
https://git.kernel.org/arm64/c/386a74677be1
--
Catalin
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel