Re: [PATCH 3/3] dt-bindings: bus: ti-sysc: Update to use yaml binding
From: Tony Lindgren <tony@atomide.com>
Date: 2021-10-11 05:51:02
Also in:
linux-devicetree, linux-omap, lkml
Hi, * Rob Herring [off-list ref] [211008 20:39]:
On Thu, Oct 07, 2021 at 03:48:58PM +0300, Tony Lindgren wrote:quoted
+ compatible: + oneOf: + - items: + - enum: + - ti,sysc-omap2 + - ti,sysc-omap2 + - ti,sysc-omap4 + - ti,sysc-omap4-simple + - ti,sysc-omap2-timer + - ti,sysc-omap4-timer + - ti,sysc-omap3430-sr + - ti,sysc-omap3630-sr + - ti,sysc-omap4-sr + - ti,sysc-omap3-sham + - ti,sysc-omap-aes + - ti,sysc-mcasp + - ti,sysc-dra7-mcasp + - ti,sysc-usb-host-fs + - ti,sysc-dra7-mcan + - ti,sysc-pruss + - const: ti,sysc + - items: + - const: ti,syscThis doesn't really match what the old doc said nor the old example. Fine to fix in the conversion if wrong, but just highlight that in the commit msg.
OK yes we currently always need "ti,sysc" as the clockdomain autoidle handling still relies on auxdata.
quoted
+ + reg: trueAny number of register areas is valid?
Yes the number of registers is known, I'll update to use max three reg.
quoted
+ + reg-names: trueYou've thrown out the names defined before.
Yup these are known too.
quoted
+ + clocks: trueAny number of clocks is valid?
I think 8 clocks is the highest seen :)
quoted
+ clock-names: trueYou've thrown out the names defined before.
Hmm fck and ick can be named, the rest are device specific though.
quoted
+ + power-domains: trueHow many?
Just one should be enough here.
quoted
+additionalProperties: trueThis can be restricted to child nodes only? If so: additionalProperties: type: object
OK great, this can be limited to child nodes only. Regards, Tony _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel