Thread (9 messages) 9 messages, 2 authors, 2021-08-23

Re: [PATCH v3 2/2] remoteproc: meson-mx-ao-arc: Add a driver for the AO ARC remote procesor

From: Mathieu Poirier <mathieu.poirier@linaro.org>
Date: 2021-08-23 15:29:35
Also in: linux-amlogic, linux-remoteproc, lkml

On Thu, Aug 05, 2021 at 10:15:06AM -0600, Mathieu Poirier wrote:
On Wed, Aug 04, 2021 at 11:03:57PM +0200, Martin Blumenstingl wrote:
quoted
Hi Mathieu,

thanks for taking the time to look into this!

(I will address any of your comments that I am not mentioning in this
email anymore. Thanks a lot for the suggestions!)

On Wed, Jul 28, 2021 at 7:58 PM Mathieu Poirier
[off-list ref] wrote:
[...]
quoted
quoted
+     writel(FIELD_PREP(AO_REMAP_REG0_REMAP_AHB_SRAM_BITS_17_14_FOR_ARM_CPU,
+                            priv->sram_pa >> 14),
Indentation problem
The idea here is to align priv->sram_pa with AO_REMAP_REG0... which
are both arguments to FIELD_PREP
Right, this is what I would have expected.  When I applied the patch on my side
"priv->sram_pa ..." was aligned wiht the 'M' of "AO_REMAP_ ...".  
quoted
Maybe using something like this will make that easier to read:
    tmp = FIELD_PREP(AO_REMAP_REG0_REMAP_AHB_SRAM_BITS_17_14_FOR_ARM_CPU,
                                     priv->sram_pa >> 14);
    writel(tmp, priv->remap_base + AO_REMAP_REG0);
I think the main problem is that
AO_REMAP_REG0_REMAP_AHB_SRAM_BITS_17_14_FOR_ARM_CPU is simply too long.  I
suggest making is shorter and add a comment to describe exactly what it does.
quoted
What do you think: leave it as is or use a separate variable?

[...]
quoted
quoted
+     usleep_range(10, 100);
I've seen this kind of mysterious timeouts in other patchset based vendor trees.
You likely don't know why it is needed so I won't ask.
unfortunately this is also the case here

[...]
quoted
quoted
+     priv->arc_reset = devm_reset_control_get_exclusive(dev, NULL);
+     if (IS_ERR(priv->arc_reset)) {
Function __reset_control_get() in __devm_reset_control_get() can return NULL so
this should be IS_ERR_OR_NULL().
The logic in there is: return optional ? NULL : ERR_PTR(-...);
Ok, so you meant to do that.  And I just checked reset_control_reset() and it does
account for a NULL parameter.  I'm good with this one but add a comment to
make sure future readers don't think you've omitted to properly deal with the
NULL return value.
quoted
I am requesting a mandatory reset line here, so reset core will never
return NULL
See also [0]
Indeed, I've read that too.  Nonetheless __reset_control_get() can return NULL
by way of __reset_control_get_from_lookup().
You are correct, in your case checking for IS_ERR() is sufficient.
quoted
For this reason I am not planning to change this

[...]
quoted
This driver is squeaky clean. With the above:

Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org>
awesome, thank you!


Best regards,
Martin


[0] https://elixir.bootlin.com/linux/v5.14-rc4/source/include/linux/reset.h#L227
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help