On 8/20/21 2:01 PM, Will Deacon wrote:
On Fri, Aug 20, 2021 at 12:05:31PM +0530, Anshuman Khandual wrote:
quoted
PAGE_SHIFT (PAGE_SIZE and PAGE_MASK) which is derived from ARM64_PAGE_SHIFT
should be moved into pgtable-hwdef.h instead, and subsequently page-def.h
can be just dropped off completely.
According to who?
Every other architecture defines PAGE_SHIFT in page.h, so if you're moving
things around then that sounds like a better choice.
Sure, will change. That is why I had asked the question :)
Will
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel