Re: [PATCH 2/2] remoteproc: fix kernel doc for struct rproc_ops
From: Mathieu Poirier <mathieu.poirier@linaro.org>
Date: 2021-07-12 17:42:53
Also in:
linux-remoteproc
On Tue, Jul 06, 2021 at 10:21:56PM +0800, Dong Aisheng wrote:
The load_rsc_table was removed since the
commit c1d35c1ab424 ("remoteproc: Rename "load_rsc_table" to "parse_fw"")
but got added back again by mistake in the below commit:
commit b1a17513a2d6 ("remoteproc: add vendor resources handling").
The patch fixed a small code indent issue which not worth
a separate patch.
Fixes: b1a17513a2d6 ("remoteproc: add vendor resources handling")
Signed-off-by: Dong Aisheng <aisheng.dong@nxp.com>
---
include/linux/remoteproc.h | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)Reviewed-by: Mathieu Poirier <mathieu.poirier@linaro.org> Bjorn - checkpatch gets confused with the two double quotes in the changelog. I checked the syntax and everything is conformant to the guidelines.
quoted hunk ↗ jump to hunk
diff --git a/include/linux/remoteproc.h b/include/linux/remoteproc.h index a5b37bc10865..83c09ac36b13 100644 --- a/include/linux/remoteproc.h +++ b/include/linux/remoteproc.h@@ -369,9 +369,8 @@ enum rsc_handling_status { * @da_to_va: optional platform hook to perform address translations * @parse_fw: parse firmware to extract information (e.g. resource table) * @handle_rsc: optional platform hook to handle vendor resources. Should return - * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled and a - * negative value on error - * @load_rsc_table: load resource table from firmware image + * RSC_HANDLED if resource was handled, RSC_IGNORED if not handled + * and a negative value on error * @find_loaded_rsc_table: find the loaded resource table from firmware image * @get_loaded_rsc_table: get resource table installed in memory * by external entity-- 2.25.1
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel