Thread (6 messages) 6 messages, 2 authors, 2021-07-29

Re: [PATCH 1/3] KVM: arm64: Record number of signal exits as a vCPU stat

From: Jing Zhang <hidden>
Date: 2021-07-29 20:08:08
Also in: kvm, kvmarm, lkml

On Thu, Jul 29, 2021 at 12:56 PM Oliver Upton [off-list ref] wrote:
quoted hunk ↗ jump to hunk
Most other architectures that implement KVM record a statistic
indicating the number of times a vCPU has exited due to a pending
signal. Add support for that stat to arm64.

Cc: Jing Zhang <redacted>
Signed-off-by: Oliver Upton <redacted>
---
 arch/arm64/include/asm/kvm_host.h | 1 +
 arch/arm64/kvm/arm.c              | 1 +
 arch/arm64/kvm/guest.c            | 3 ++-
 3 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/arch/arm64/include/asm/kvm_host.h b/arch/arm64/include/asm/kvm_host.h
index 41911585ae0c..70e129f2b574 100644
--- a/arch/arm64/include/asm/kvm_host.h
+++ b/arch/arm64/include/asm/kvm_host.h
@@ -576,6 +576,7 @@ struct kvm_vcpu_stat {
        u64 wfi_exit_stat;
        u64 mmio_exit_user;
        u64 mmio_exit_kernel;
+       u64 signal_exits;
        u64 exits;
 };
diff --git a/arch/arm64/kvm/arm.c b/arch/arm64/kvm/arm.c
index e9a2b8f27792..60d0a546d7fd 100644
--- a/arch/arm64/kvm/arm.c
+++ b/arch/arm64/kvm/arm.c
@@ -783,6 +783,7 @@ int kvm_arch_vcpu_ioctl_run(struct kvm_vcpu *vcpu)
                if (signal_pending(current)) {
                        ret = -EINTR;
                        run->exit_reason = KVM_EXIT_INTR;
+                       ++vcpu->stat.signal_exits;
                }

                /*
diff --git a/arch/arm64/kvm/guest.c b/arch/arm64/kvm/guest.c
index 1dfb83578277..50fc16ad872f 100644
--- a/arch/arm64/kvm/guest.c
+++ b/arch/arm64/kvm/guest.c
@@ -50,7 +50,8 @@ const struct _kvm_stats_desc kvm_vcpu_stats_desc[] = {
        STATS_DESC_COUNTER(VCPU, wfi_exit_stat),
        STATS_DESC_COUNTER(VCPU, mmio_exit_user),
        STATS_DESC_COUNTER(VCPU, mmio_exit_kernel),
-       STATS_DESC_COUNTER(VCPU, exits)
+       STATS_DESC_COUNTER(VCPU, exits),
+       STATS_DESC_COUNTER(VCPU, signal_exits),
How about put signal_exits before exits as the same order in
kvm_vcpu_stat just for readability?
 };
 static_assert(ARRAY_SIZE(kvm_vcpu_stats_desc) ==
                sizeof(struct kvm_vcpu_stat) / sizeof(u64));
--
2.32.0.554.ge1b32706d8-goog
Reviewed-by: Jing Zhang <redacted>

Thanks,
Jing

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help