Re: [PATCH v8 12/19] sched: Introduce task_cpus_dl_admissible() to check proposed affinity
From: Daniel Bristot de Oliveira <hidden>
Date: 2021-06-03 09:43:18
Also in:
linux-arch, lkml
On 6/2/21 6:47 PM, Will Deacon wrote:
quoted hunk ↗ jump to hunk
In preparation for restricting the affinity of a task during execve() on arm64, introduce a new task_cpus_dl_admissible() helper function to give an indication as to whether the restricted mask is admissible for a deadline task. Signed-off-by: Will Deacon <will@kernel.org> --- include/linux/sched.h | 6 ++++++ kernel/sched/core.c | 44 +++++++++++++++++++++++++++---------------- 2 files changed, 34 insertions(+), 16 deletions(-)diff --git a/include/linux/sched.h b/include/linux/sched.h index 91a6cfeae242..9b17d8cfa6ef 100644 --- a/include/linux/sched.h +++ b/include/linux/sched.h@@ -1691,6 +1691,7 @@ extern void do_set_cpus_allowed(struct task_struct *p, const struct cpumask *new extern int set_cpus_allowed_ptr(struct task_struct *p, const struct cpumask *new_mask); extern int dup_user_cpus_ptr(struct task_struct *dst, struct task_struct *src, int node); extern void release_user_cpus_ptr(struct task_struct *p); +extern bool task_cpus_dl_admissible(struct task_struct *p, const struct cpumask *mask); extern void force_compatible_cpus_allowed_ptr(struct task_struct *p); extern void relax_compatible_cpus_allowed_ptr(struct task_struct *p); #else@@ -1713,6 +1714,11 @@ static inline void release_user_cpus_ptr(struct task_struct *p) { WARN_ON(p->user_cpus_ptr); } + +static inline bool task_cpus_dl_admissible(struct task_struct *p, const struct cpumask *mask) +{ + return true; +} #endif extern int yield_to(struct task_struct *p, bool preempt);diff --git a/kernel/sched/core.c b/kernel/sched/core.c index 58e2cf7520c0..b4f8dc18ae11 100644 --- a/kernel/sched/core.c +++ b/kernel/sched/core.c@@ -6933,6 +6933,31 @@ SYSCALL_DEFINE4(sched_getattr, pid_t, pid, struct sched_attr __user *, uattr, return retval; } +#ifdef CONFIG_SMP +bool task_cpus_dl_admissible(struct task_struct *p, const struct cpumask *mask)
Would you mind renaming it to dl_task_check_affinity(), in the case of a v9? It will look coherent with dl_task_can_attach()... Reviewed-by: Daniel Bristot de Oliveira <redacted> Thanks! -- Daniel _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel