Re: [RFC PATCH v2 02/10] genirq: Define irq_ack() and irq_eoi() helpers
From: Valentin Schneider <hidden>
Date: 2021-06-01 10:25:32
Also in:
lkml
On 27/05/21 11:58, Marc Zyngier wrote:
On Thu, 27 May 2021 11:55:50 +0100, Marc Zyngier [off-list ref] wrote:quoted
On Tue, 25 May 2021 18:32:47 +0100, Valentin Schneider [off-list ref] wrote:quoted
diff --git a/kernel/irq/internals.h b/kernel/irq/internals.h index b6c1cceddec0..090bd7868845 100644 --- a/kernel/irq/internals.h +++ b/kernel/irq/internals.h@@ -87,6 +87,8 @@ extern void irq_enable(struct irq_desc *desc); extern void irq_disable(struct irq_desc *desc); extern void irq_percpu_enable(struct irq_desc *desc, unsigned int cpu); extern void irq_percpu_disable(struct irq_desc *desc, unsigned int cpu); +extern void irq_ack(struct irq_desc *desc); +extern void irq_eoi(struct irq_desc *desc);Nit: we have {un,}mask_irq, but you add irq_{ack,eoi}. It'd be good to have some naming consistency (yes, this may/will clash with existing code, but we can fix that as well).Actually, the helpers do have the right naming, but the internal declarations are the ones that are wrong...
Doh!
M. -- Without deviation from the norm, progress is not possible.
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel