Re: [PATCH v2 09/19] arm64: entry: organise entry vectors consistently
From: Joey Gouly <joey.gouly@arm.com>
Date: 2021-05-21 16:09:20
From: Joey Gouly <joey.gouly@arm.com>
Date: 2021-05-21 16:09:20
On Wed, May 19, 2021 at 01:38:52PM +0100, Mark Rutland wrote:
In subsequent patches we'll rename the entry handlers based on their original EL, register width, and exception class. To do so, we need to make all 3 mandatory arguments to the `kernel_ventry` macro, and distinguish EL1h from EL1t. In preparation for this, let's make the current set of arguments mandatory, and move the `regsize` column before the branch label suffix, making the vectors easier to read column-wise. There should be no functional change as a result of this patch.
Reviewed-by: Joey Gouly <joey.gouly@arm.com> _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel