RE: [PATCH 2/2] mm: Indicate pfmemalloc pages in compound_head
From: David Laight <hidden>
Date: 2021-04-17 21:13:54
Also in:
linux-mips, linux-mm, linuxppc-dev, lkml, netdev
From: David Laight <hidden>
Date: 2021-04-17 21:13:54
Also in:
linux-mips, linux-mm, linuxppc-dev, lkml, netdev
From: Matthew Wilcox (Oracle) <willy@infradead.org>
Sent: 17 April 2021 00:07 The net page_pool wants to use a magic value to identify page pool pages. The best place to put it is in the first word where it can be clearly a non-pointer value. That means shifting dma_addr up to alias with ->index, which means we need to find another way to indicate page_is_pfmemalloc(). Since page_pool doesn't want to set its magic value on pages which are pfmemalloc, we can use bit 1 of compound_head to indicate that the page came from the memory reserves.
...
struct { /* page_pool used by netstack */
- /**
- * @dma_addr: might require a 64-bit value on
- * 32-bit architectures.
- */
+ unsigned long pp_magic;
+ unsigned long xmi;
+ unsigned long _pp_mapping_pad;
unsigned long dma_addr[2];
};You've deleted the comment. I also think there should be a comment that dma_addr[0] must be aliased to ->index. (Or whatever all the exact requirements are.) David - Registered Address Lakeside, Bramley Road, Mount Farm, Milton Keynes, MK1 1PT, UK Registration No: 1397386 (Wales) _______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel