On Mon, Mar 29, 2021 at 8:54 PM Andy Shevchenko
[off-list ref] wrote:
On Sat, Mar 06, 2021 at 07:36:30PM +0530, Syed Nayyar Waris wrote:
quoted
This patch reimplements the xgpio_set_multiple() function in
drivers/gpio/gpio-xilinx.c to use the new generic functions:
bitmap_get_value() and bitmap_set_value(). The code is now simpler
to read and understand. Moreover, instead of looping for each bit
in xgpio_set_multiple() function, now we can check each channel at
a time and save cycles.
...
quoted
+ u32 *const state = chip->gpio_state;
Looking at this... What's the point of the const here?
Am I right that this tells: pointer is a const, while the data underneath
can be modified?
Yes you are right and the data underneath can be modified.
I have removed the 'const' in v4
quoted
+ unsigned int *const width = chip->gpio_width;
Ditto.
Putting const:s here and there for sake of the const is not good practice.
It makes code harder to read.
Okay.
--
With Best Regards,
Andy Shevchenko
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel