Thread (21 messages) 21 messages, 4 authors, 2021-02-22

Re: [PATCH v18 02/11] arm64: Rename kexec elf_headers_mem to elf_load_addr

From: Thiago Jung Bauermann <hidden>
Date: 2021-02-15 21:35:48
Also in: linux-devicetree, linux-integrity, linuxppc-dev, lkml

Lakshmi Ramasubramanian [off-list ref] writes:
The architecture specific field, elf_headers_mem in struct kimage_arch,
that holds the address of the buffer in memory for ELF core header for
arm64 has a different name than the one used for powerpc.  This makes
it hard to have a common code for setting up the device tree for
kexec system call.

Rename elf_headers_mem to elf_load_addr to align with powerpc name so
common code can use it.

Signed-off-by: Lakshmi Ramasubramanian <redacted>
Suggested-by: Thiago Jung Bauermann <redacted>
---
 arch/arm64/include/asm/kexec.h         | 2 +-
 arch/arm64/kernel/machine_kexec_file.c | 6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)
Reviewed-by: Thiago Jung Bauermann <redacted>

-- 
Thiago Jung Bauermann
IBM Linux Technology Center

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help