Thread (65 messages) 65 messages, 3 authors, 2020-11-06

Re: [PATCH v8 18/43] kasan, arm64: rename kasan_init_tags and mark as __init

From: Catalin Marinas <catalin.marinas@arm.com>
Date: 2020-11-05 16:00:14
Also in: linux-mm, lkml

On Thu, Nov 05, 2020 at 12:18:33AM +0100, Andrey Konovalov wrote:
Rename kasan_init_tags() to kasan_init_sw_tags() as the upcoming hardware
tag-based KASAN mode will have its own initialization routine.
Also similarly to kasan_init() mark kasan_init_tags() as __init.

Signed-off-by: Andrey Konovalov <redacted>
Reviewed-by: Catalin Marinas <catalin.marinas@arm.com>

_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help