Thread (59 messages) 59 messages, 5 authors, 2020-09-01

Re: [PATCH 06/19] drm/msm/gpu: add dev_to_gpu() helper

From: Rob Clark <hidden>
Date: 2020-09-01 15:53:19
Also in: dri-devel, linux-arm-msm, linux-iommu, lkml

On Mon, Aug 31, 2020 at 9:32 PM Bjorn Andersson
[off-list ref] wrote:
On Thu 13 Aug 21:41 CDT 2020, Rob Clark wrote:
quoted
From: Rob Clark <redacted>

In a later patch, the drvdata will not directly be 'struct msm_gpu *',
so add a helper to reduce the churn.

Signed-off-by: Rob Clark <redacted>
---
 drivers/gpu/drm/msm/adreno/adreno_device.c | 10 ++++------
 drivers/gpu/drm/msm/msm_gpu.c              |  6 +++---
 drivers/gpu/drm/msm/msm_gpu.h              |  5 +++++
 3 files changed, 12 insertions(+), 9 deletions(-)
diff --git a/drivers/gpu/drm/msm/adreno/adreno_device.c b/drivers/gpu/drm/msm/adreno/adreno_device.c
index 9eeb46bf2a5d..26664e1b30c0 100644
--- a/drivers/gpu/drm/msm/adreno/adreno_device.c
+++ b/drivers/gpu/drm/msm/adreno/adreno_device.c
@@ -282,7 +282,7 @@ struct msm_gpu *adreno_load_gpu(struct drm_device *dev)
      int ret;

      if (pdev)
-             gpu = platform_get_drvdata(pdev);
+             gpu = dev_to_gpu(&pdev->dev);

      if (!gpu) {
              dev_err_once(dev->dev, "no GPU device was found\n");
@@ -425,7 +425,7 @@ static int adreno_bind(struct device *dev, struct device *master, void *data)
 static void adreno_unbind(struct device *dev, struct device *master,
              void *data)
 {
-     struct msm_gpu *gpu = dev_get_drvdata(dev);
+     struct msm_gpu *gpu = dev_to_gpu(dev);

      pm_runtime_force_suspend(dev);
      gpu->funcs->destroy(gpu);
@@ -490,16 +490,14 @@ static const struct of_device_id dt_match[] = {
 #ifdef CONFIG_PM
 static int adreno_resume(struct device *dev)
 {
-     struct platform_device *pdev = to_platform_device(dev);
-     struct msm_gpu *gpu = platform_get_drvdata(pdev);
+     struct msm_gpu *gpu = dev_to_gpu(dev);

      return gpu->funcs->pm_resume(gpu);
 }

 static int adreno_suspend(struct device *dev)
 {
-     struct platform_device *pdev = to_platform_device(dev);
-     struct msm_gpu *gpu = platform_get_drvdata(pdev);
+     struct msm_gpu *gpu = dev_to_gpu(dev);

      return gpu->funcs->pm_suspend(gpu);
 }
diff --git a/drivers/gpu/drm/msm/msm_gpu.c b/drivers/gpu/drm/msm/msm_gpu.c
index d5645472b25d..6aa9e04e52e7 100644
--- a/drivers/gpu/drm/msm/msm_gpu.c
+++ b/drivers/gpu/drm/msm/msm_gpu.c
@@ -24,7 +24,7 @@
 static int msm_devfreq_target(struct device *dev, unsigned long *freq,
              u32 flags)
 {
-     struct msm_gpu *gpu = platform_get_drvdata(to_platform_device(dev));
+     struct msm_gpu *gpu = dev_to_gpu(dev);
      struct dev_pm_opp *opp;

      opp = devfreq_recommended_opp(dev, freq, flags);
@@ -45,7 +45,7 @@ static int msm_devfreq_target(struct device *dev, unsigned long *freq,
 static int msm_devfreq_get_dev_status(struct device *dev,
              struct devfreq_dev_status *status)
 {
-     struct msm_gpu *gpu = platform_get_drvdata(to_platform_device(dev));
+     struct msm_gpu *gpu = dev_to_gpu(dev);
      ktime_t time;

      if (gpu->funcs->gpu_get_freq)
@@ -64,7 +64,7 @@ static int msm_devfreq_get_dev_status(struct device *dev,

 static int msm_devfreq_get_cur_freq(struct device *dev, unsigned long *freq)
 {
-     struct msm_gpu *gpu = platform_get_drvdata(to_platform_device(dev));
+     struct msm_gpu *gpu = dev_to_gpu(dev);

      if (gpu->funcs->gpu_get_freq)
              *freq = gpu->funcs->gpu_get_freq(gpu);
diff --git a/drivers/gpu/drm/msm/msm_gpu.h b/drivers/gpu/drm/msm/msm_gpu.h
index 0db117a7339b..8bda7beaed4b 100644
--- a/drivers/gpu/drm/msm/msm_gpu.h
+++ b/drivers/gpu/drm/msm/msm_gpu.h
@@ -141,6 +141,11 @@ struct msm_gpu {
      struct msm_gpu_state *crashstate;
 };

+static inline struct msm_gpu *dev_to_gpu(struct device *dev)
That's a fairly generic name for a driver-global helper :)
tbf, it is only global to the gpu part of the driver..

thanks for the review

BR,
-R
Reviewed-by: Bjorn Andersson <redacted>

Regards,
Bjorn
quoted
+{
+     return dev_get_drvdata(dev);
+}
+
 /* It turns out that all targets use the same ringbuffer size */
 #define MSM_GPU_RINGBUFFER_SZ SZ_32K
 #define MSM_GPU_RINGBUFFER_BLKSIZE 32
--
2.26.2
_______________________________________________
linux-arm-kernel mailing list
linux-arm-kernel@lists.infradead.org
http://lists.infradead.org/mailman/listinfo/linux-arm-kernel
Keyboard shortcuts
hback out one level
jnext message in thread
kprevious message in thread
ldrill in
Escclose help / fold thread tree
?toggle this help