Re: [PATCH v10 4/5] rtc: mt6397: Add support for the MediaTek MT6358 RTC
From: Ran Bi <hidden>
Date: 2020-03-12 08:58:19
Also in:
linux-devicetree, linux-mediatek, linux-pm, linux-rtc, lkml
On Thu, 2020-03-12 at 07:44 +0000, Lee Jones wrote:
On Wed, 11 Mar 2020, Hsin-Hsiung Wang wrote:quoted
From: Ran Bi <redacted> This add support for the MediaTek MT6358 RTC. Driver using compatible data to store different RTC_WRTGR address offset. This replace RTC_WRTGR to RTC_WRTGR_MT6323 in mt6323-poweroff driver which only needed by armv7 CPU without ATF. Signed-off-by: Ran Bi <redacted> Signed-off-by: Hsin-Hsiung Wang <redacted> --- drivers/power/reset/mt6323-poweroff.c | 2 +- drivers/rtc/rtc-mt6397.c | 32 ++++++++++++++++++++++++-------- include/linux/mfd/mt6397/rtc.h | 9 ++++++++- 3 files changed, 33 insertions(+), 10 deletions(-)
<...>
quoted
#define RTC_IRQ_STA 0x0002 #define RTC_IRQ_STA_AL BIT(0)@@ -65,6 +67,10 @@ #define MTK_RTC_POLL_DELAY_US 10 #define MTK_RTC_POLL_TIMEOUT (jiffies_to_usecs(HZ)) +struct mtk_rtc_data { + u32 wrtgr; +};Do you expect to add more properties to this struct? If not, it seems a bit overkill.
Yes, we would add more properties here in future patches.
quoted
struct mt6397_rtc { struct device *dev; struct rtc_device *rtc_dev;@@ -74,6 +80,7 @@ struct mt6397_rtc { struct regmap *regmap; int irq; u32 addr_base; + const struct mtk_rtc_data *data;'data' is a terrible variable name. Why do you need to store this? It's one variable which is used once AFAICT.
I would rename 'data' to 'config'. This struct will be extended in future patches to achieve more PMIC chip compatibility.
quoted
}; #endif /* _LINUX_MFD_MT6397_RTC_H_ */
_______________________________________________ linux-arm-kernel mailing list linux-arm-kernel@lists.infradead.org http://lists.infradead.org/mailman/listinfo/linux-arm-kernel